My custom fields don't seem to be showing up, did I do something wrong?

You might want to check if you added the correct suffix to your custom data field.

Custom fields have a special format, including both the name and the type of the field, so that we know how to display them in the UI. The type options are str, int, real, date and bool. For example, If I wanted to add a field called "Account Status" that is of type "string", I would name the field "accountStatus_str". Note that underscores are used to delimit the type of the field, so it is best if you don't use them in the name of your field. Capital letters are used to denote separate words in the field name.

Once you've got the field names updated, you should see the custom fields show up in the search UI (click the magnifying glass in the upper right corner, select "Any User" and scroll to the bottom). This will allow you to filter based on your custom field. You can also see the custom data for any user by clicking on them in the user list. All of their data will show up on the right side under their name and email address.

Also, you may want to double check that they didn't get turned off! Navigate to Settings > Recording & Exclusions and scroll to the bottom of the page. You should see a list of all of your custom variables and they should all be set to "Visible".

You can find more information in our Developer Docs

Was this article helpful?

/

Can’t find what you’re looking for?

The FullStory team awaits your every question.

Contact Us